Can't use the language subsetting of a webfont

Good day,

I’m trying to use the Bulgarian characters that are part of the Cyrillic subsetting of the Montserrat font using this CSS rule: font-feature-settings: "locl" 1;.

What I did so far is:

  1. Use the Webfont Generator;
  2. choose the custom subsetting and then Cyrillic from the languages;
  3. tried with and without the Keep All Features option from the OpenType Features;
  4. used the generated woff and woff2 files.
  5. used the font-feature-settings: "locl" 1; style.

Sadly, I’m still getting the default characters for л, д and г. When I open the font with FontForge to explore the character table I see that the characters I want are included in the generated webfont, but just specifying the font feature settings doesn’t seem to be enough.

The worst thing is that I had the same issue one year ago and I somehow solved it but didn’t document the process at all.

Thanks in advanced,

After trying all sorts of combination in the Webfont Generator I found that the issue wasn’t in the webfont or in the settings set in the CSS, BUT in the html document itself, it was missing a lang="" attribute in it’s <html> tag…

Bottom line:

  • No need to self-host a Google font to use the localisation setting;
  • the localisation setting is set in the <html> tag of the HTML document;
  • mozilla supports font-language-override css rule;
  • I found out that the language specific characters aren’t part of the style subsets (thus self-hosting the font is not required).

ps: This matter still feels very confusing to me… :confused: